Sharedsupport / 2014-11-25-homology-bug.sagewsOpen in CoCalc
Authors: Harald Schilly, ℏal Snyder, William A. Stein
License: GNU General Public License v3.0
Description: Examples for support purposes.
D = ChainComplex({0: identity_matrix(ZZ, 4), 4: identity_matrix(ZZ, 30)}) D.homology()
{}
!sage -optional
Using Sage Server http://www.sagemath.org/packages Optional packages: 4ti2-1.6.2 .............................. already installed PyQt_x11-4.9.1.p0 ....................... not installed TOPCOM-0.17.4 ........................... not installed autotools-20121217 ...................... not installed beautifulsoup-3.2.1 ..................... not installed benzene-20130630 ........................ not installed biopython-1.61 .......................... already installed brian-1.4.1.p0 .......................... not installed buckygen-1.0.p1 ......................... not installed cbc-2.8.1.p0 ............................ already installed ccache-3.1.9 ............................ not installed chomp-20130518.p1 ....................... already installed cluster_seed-1.0 ........................ already installed coxeter3-1.1 ............................ already installed cryptominisat-2.9.6 ..................... already installed cunningham_tables-1.0 ................... already installed database_cremona_ellcurve-20121022 ...... installed version: 20140829 database_gap-4.6.4 ...................... installed version: 4.7.5 database_jones_numfield-v4 .............. already installed database_kohel-20060803 ................. already installed database_odlyzko_zeta ................... already installed database_pari-20130516 .................. already installed database_stein_watkins_mini.p0 .......... not installed database_symbolic_data-20070206 ......... already installed dot2tex-2.8.7.p2 ........................ installed version: 20120520 extra_docs-20070208 ..................... not installed gap_packages-4.6.4.p1 ................... installed version: 4.7.5 gcc-4.6.4 ............................... not installed gdbm-1.8.3 .............................. not installed ginv-1.9-20080723 ....................... not installed git-1.7.12.2.p0 ......................... installed version: 2.1.2 gnuplotpy-1.8 ........................... already installed guppy-0.1.8 ............................. already installed java3d-20070901 ......................... not installed kash3-2008-07-31.p0 ..................... already installed knoboo-20080411 ......................... not installed libogg-1.1.4 ............................ not installed libtheora-1.1.1 ......................... not installed lie-2.2.2.p5 ............................ already installed lrs-4.2b.p1 ............................. already installed mpi4py-1.2.2 ............................ not installed nauty-25 ................................ already installed normaliz-2.8.p0 ......................... not installed nose-1.1.2 .............................. installed version: 1.3.3 nzmath-1.1.0 ............................ already installed openmpi-1.4.3 ........................... not installed openssl-1.0.1c.p0 ....................... not installed ore_algebra-0.2 ......................... already installed p_group_cohomology-2.1.4.p1 ............. already installed patchbot-2.2 ............................ not installed phc-2.3.65.p0 ........................... already installed pybtex-20120618 ......................... already installed pycryptoplus-20100809-git ............... already installed pyopenssl-0.13.p0 ....................... not installed pyx-0.10 ................................ already installed pyzmq-2.1.11.p1 ......................... installed version: 14.3.0 qhull-2010.1 ............................ already installed sage_mode-0.10 .......................... not installed sip-4.13.2.p0 ........................... not installed trac-0.11.5.p0 .......................... not installed valgrind-3.8.1.p0 ....................... not installed zeromq-3.2.0.p0 ......................... installed version: 4.0.4 Type 'sage -i package_name' to download and install a package.